perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Green <and...@article7.co.uk>
Subject Upgrading a mod_perl application from Apache 2.2 to Apache 2.4
Date Fri, 30 Nov 2018 09:58:01 GMT
Hi,

The time has finally come for me to update my mod_perl CMS from Apache 2.2 to Apache 2.4,
but I’m struggling to find documentation on the changes required.

The docs on perl.apache.org don’t seem to mention anything specific to Apache 2.4, and the
Apache server documentation talks about its own API rather than the mod_perl interface to
it, so it’s a bit high-level for me to properly grok.

Does anyone know of a summary of the changes to mod_perl application code required, like the
ones that exist for porting mod_perl 1 applications to mod_perl 2?

Also, I’ll need to be able to run my app on both Apache 2.2 and Apache 2.4 servers.  Is
there anything in the API that would let me determine which one is in use, so that I can allow
for both in my code?

Many thanks for any pointers!

Cheers,
Andrew.

-- 
Andrew Green
Article Seven Limited
http://www.article7.co.uk/

Article Seven Limited is a registered company in England and Wales.  Registered number: 5703656.
Registered office: 10 Hamilton Road, Sidcup, Kent, DA15 7HB.





Mime
View raw message