perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sujeeva Seneviratne <sujeeva_senevira...@yahoo.com>
Subject Re: Upgrading a mod_perl application from Apache 2.2 to Apache 2.4
Date Fri, 30 Nov 2018 14:41:24 GMT
If you have an Authen handler, you may need this change:Debug Apache 2.4 PerlAuthenHandler

  
|  
|   
|   
|   |    |

   |

  |
|  
|   |  
Debug Apache 2.4 PerlAuthenHandler
 I am trying to debug a problem that occured after an apache upgrade. I want to integrate
redmine into my apache ...  |   |

  |

  |

 

I had to add:  $r->user('');  in my authen methods.
      From: Vincent Veyron <vv.lists@wanadoo.fr>
 To: modperl@perl.apache.org 
 Sent: Friday, November 30, 2018 7:41 AM
 Subject: Re: Upgrading a mod_perl application from Apache 2.2 to Apache 2.4
   
On Fri, 30 Nov 2018 09:58:01 +0000
Andrew Green <andrew@article7.co.uk> wrote:

> 
> Does anyone know of a summary of the changes to mod_perl application code required, 

I had to :

-modify the configuration files of my virtual hosts to include the new 'Require all granted'
directive, as explained in 
http://httpd.apache.org/docs/2.4/upgrading.html
which Adam mentionned

-modify a couple lines of code using $c->client_ip(), because of a change of names in the
Apache API and the connection object 

-modify the configuration of mod_deflate, which post upgrade would run before my PerlOuputFilterHandler
instead of after it (something changed in the processing order of the filter queue; the solution
was found here :
https://github.com/h5bp/html5-boilerplate/issues/1012)

Other than that, everything went smoothly


-- 
                    Bien à vous, Vincent Veyron 

https://compta.libremen.com
Logiciel libre de comptabilité générale en partie double

   
Mime
View raw message