perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Prime <adam.pr...@utoronto.ca>
Subject Re: supporting differing versions of same perl module
Date Thu, 24 Nov 2016 16:24:07 GMT

On 16-11-24 07:22 AM, mod_perl@trodman.com wrote:
> Assume two endpoint URLs, one using the current and one using an old
> version of a perl module foo.pm for our application. This 2008 article
> shows how to prevent conflicts (old app using new foo.pm or vv)
> for this situation under modperl:
>
>     http://www.slideshare.net/shixilun/module-versioning-with-apache-1x-and-modperl-1x
>     ( 2008. HTML:Mason involved )
>
> What is the new best practice?
>

This is one of the things PerlOptions +Clone is supposed to be able to 
help with, but i personally have no experience with using or setting it up.

This blog post might be helpful in getting it setup and working:

https://larig.wordpress.com/2010/06/13/apache-configurations-for-perl/

Adam





Mime
View raw message