perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve.m....@googlemail.com>
Subject Re: Issue while compiling mod_perl-2.0.8 with Apache 2.4.3
Date Thu, 09 Apr 2015 12:38:24 GMT
On 9 April 2015 at 10:35, Sailaja Gadireddy <sailaja.gadireddy@gmail.com>
wrote:

> Hello Team,
>
> We are facing issue while compiling mod_perl to Aapche.
>
> perl Makefile.PL MP_APXS=/Apachepath/apxs
>
> It gave the below erorr.
>
>  bash-3.2# perl Makefile.PL MP_APXS=/opt/web/apache_test/bin/apxs
> MP_APR_CONFIG=/opt/app/software/httpd-2.4.3/srclib
>
>
>
>
>
>
>
> */apr/apr-1-config -DuseithreadsReading Makefile.PL args from @ARGV
> MP_APXS = /opt/web/apache_test/bin/apxs MP_APR_CONFIG =
> /opt/app/software/httpd-2.4.3/srclib/apr/apr-1-configno conflicting prior
> mod_perl version found - good.Configuring Apache/2.4.3 mod_perl/2.0.8
> Perl/v5.8.4[ error] Using Perl 5.8.4 w/o ithreads and 'dynamic' mpm httpd.[
> error] Failed requirements:[ error] - Perl built with ithreads (build perl
> with -Duseithreads)*
>
>
>
The error message is fairly clear: You are trying to use a perl built
without -Duseithreads, but this is not possible with the threaded MPM of
your httpd. You will need to rebuild perl with -Duseithreads, or else use a
non-threaded httpd MPM.

However, I also notice that you're trying to build mod_perl-2.0.8 with an
httpd-2.4. The latter is not yet supported by mod_perl, although we're very
close now to releaseing 2.0.9 with httpd-2.4 support. In the meantime you
might like to try checking out
https://svn.apache.org/repos/asf/perl/modperl/trunk .

Mime
View raw message