perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patton, Billy N" <billy.pat...@h3net.com>
Subject installing mod perl 2.08 on MAC 10.10
Date Thu, 13 Nov 2014 14:28:45 GMT
I recently upgraded to 10.10 Yosemite.
After that it wiped out a lot of work I had done for apache and mod_perl.
I also install perlbrew to install everything in my home.
I’m trying to reinstall mod perl but cannot get the configure to work.
I’m reinstalling because some of the modules in perl have not been upgraded to perl 5.18
that comes with yosemite.
And when I try and run my app I get errors that refer to modules in /Library/Perl/…
On the we I read that I would need to recompile mod_perl to get it to use my perlbrew version.
This is where the problem started.
I have installed the MAC command line tools for 10.10.
I’ve installed apr-1.5.1 and apr-util-1.5.3

I get this error :
$ perl Makefile.PL MP_APXS=/usr/sbin/apxs
Reading Makefile.PL args from @ARGV
   MP_APXS = /usr/sbin/apxs
no conflicting prior mod_perl version found - good.
Configuring Apache/2.4.9 mod_perl/2.0.8 Perl/v5.16.0
[  error] Can't find apr include/ directory,
[  error] use MP_APR_CONFIG=/path/to/apr-config
Mime
View raw message