perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Powell <papow...@astart.com>
Subject Apache 24 + mod_perl
Date Fri, 01 Aug 2014 21:09:06 GMT
Question:  when will mod_perl be available for Apache 24?  Is anybody 
using it (see below), and what problems (if any) were there?  The method 
outlined below may or may not work - I haven't tried it.  Any comments 
or suggestions?

Background:

I wanted to update to Apache 24/FreeBSD 9.2. Everything went fine until 
I hit mod_perl.  The
current Port Makefile as of Fri 01 Aug 2014 is marked as:

.if ${APACHE_VERSION} > 22
BROKEN= Does not build with apache24
.endif

Apparently mod_perl is currently not compatible with Apache24.  The 
perl-modperl mailing list has a posting:

http://mail-archives.apache.org/mod_mbox/perl-modperl/201402.mbox/%3CCADED=K4p2HFc6K1San3MPmm8vZ+gwT5rsiJ5sAMVLRV7z5z-gA@mail.gmail.com%3E

This has the following information:
Date: Sun, 16 Feb 2014 15:36:18 GMT

> The Debian project is shipping mod_perl with httpd24 support
> based on http://svn.apache.org/repos/asf/perl/modperl/branches/httpd24/.

An update on the state of things regarding httpd-2.4 support in mod_perl:

We are working hard to get this done and are 99% of the way there.
Both volunteers and volunteers' time is limited, though, so progress
has been slow. A lot of work has taken place in the httpd24 branch,
and as Dominic says, some Linux distros are already shipping that.

There is also a posting on how to abuse the mod_perl2 port, download the 
source from the SVN repository and force mod_perl2 to compile it:

https://forums.freebsd.org/viewtopic.php?f=5&t=46523




Mime
View raw message