perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Da Rock <mod_p...@herveybayaustralia.com.au>
Subject Initial setup problems with mod_perl2 - unable to locate modules
Date Fri, 14 Feb 2014 13:37:24 GMT
I know this may seem straight forward and a RTFM response may be in 
order, but I have been trying to crack this for some days now (following 
attempts on and off, too, mind) and nothing I can google seems to point 
to an accurate answer on what the problem is here.

I'm running FreeBSD 9.x with Apache22, and installed mod_perl2 to try to 
switch away from php based development based on current requirements.

I have tried using a startup.pl, but I would like to just use 
PerlSwitches -I instead (which from what I read is possible); regardless 
the issue remains the same.

I get a 500 response in the browser, and the logs have these errors:

"failed to resolve handler `Mod_home::Mod': Can't locate Mod_home/Mod.pm 
in @INC"

and simply "failed to resolve handler" in the main server log.

My config looks like this:

<VirtualHost <IP>:<PORT>>
     ServerName <server>
     ServerAlias <server>
     ServerAdmin <hostmaster>
     ErrorLog "/var/log/apache/<VHOST>-error.log"
     CustomLog "/var/log/apache/<VHOST>-access.log" common
     PerlOptions +Parent
     PerlSwitches -I/usr/local/www/<VHOST>/lib
     PerlInitHandler Apache2::Reload
     PerlModule Mod_home::Mod
     <Location /<VHOST>>
         SetHandler modperl
         PerlResponseHandler Mod_home::Mod
         Order allow,deny
         Allow from all
     </Location>
</VirtualHost>

I also have PerlModule Apache2::Reload in the httpd.conf.

Just to reiterate - I have tried this both as vhosting and as single 
server setup, and I cannot seem to resolve the same issue every single time.

Can someone please give the magical incantation to make this thing work? 
:-) or at least point me in the right direction? I'm really starting to 
lose patience with this thing, and I now have a deadline to sort this 
out which is fast approaching.

Cheers

Mime
View raw message