Hi All,

 

I have Apache/2.2.22 and Perl/v5.18.0 and setting up mod_perl/2.0.7.

 

While installing mod_perl I am getting the following error:

 

  file /install/perl/v5.18/perl
gives
/install/perl/v5.18/perl: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

  Command to build mod_perl:
/install/perl/v5.18/perl Makefile.PL MP_APXS=/export/apache/bin/apxs

  Result:

Reading Makefile.PL args from @ARGV

   MP_APXS = /export/apache/bin/apxs

no conflicting prior mod_perl version found - good.

Configuring Apache/2.2.22 mod_perl/2.0.7 Perl/v5.18.0

[  error] Using Perl 5.018000 w/o ithreads and 'worker' mpm httpd.

[  error] Failed requirements:

[  error]   - Perl built with ithreads (build perl with -Dusethreads)

 

As recommended in the last line – “build perl with –Dusethreads” I tried that while setting up perl but the same error.

 

Please share your inputs to resolve this.

 

Thanks,

Rommel.