perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Re: Install Question
Date Mon, 03 Jun 2013 16:43:03 GMT
On Mon, Jun 3, 2013 at 8:42 AM, Tracy Kukuselis <tkukuselis@verizon.net> wrote:
> I am trying to install modperl 2.0.3 with httpd 2.4.2 (also tried 2.4.4),
> but am getting the following error:

2.4 isn't officially supported yet, although there are a couple builds
on the list you might try. See the list archives for those.

> Failed to obtain the MPM name. Please specify MP_APXS=/full/path/to/apxs to
> solve this problem.
> make:*** [path] Error 255

What OS and Perl version are you running? What command are you using
to build mod_perl? Do you know where your apxs executable is? ('which
apxs' should output the location).

>
> Using the following configure command
> configure --prefix=/usr/local/apache2 --disable-userdir --enable-expires
> --enable-headers --enable-ldap --enable-logio --enable-mime-magic
> --enable-so --enable-speling --endable-usertrack --enable-vhost-alias
> --with-port=80 --with-included-apr --with-included-apr-util
> --with-ssl=/usr/local/ssl/
>
> Where can I put the MPM name to get it to be picked up.   I tried to add
> --mpm-name=prefork, to the configure command, but the same problem.
>
>
> Thanks
> Tracy
>
>

Mime
View raw message