perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Perrin Harkins <phark...@gmail.com>
Subject Re: Apache::DBI "connection lost contact" error
Date Thu, 13 Jun 2013 15:03:46 GMT
That's unfortunate.  Are you using it the same way, with a DBI connection
in a <Perl> block?  I haven't seen anyone else mention a problem with it in
Apache 1.

- Perrin


On Wed, Jun 12, 2013 at 5:05 PM, Xinhuan Zheng <xzheng@christianbook.com>wrote:

>  Hi Perrin,
>
>  Today I tested the Apache-DBI 1.12 with Apache 1.3.42 and mod_perl 1. We
> have to use mod_perl 1 in some situations. There is same issue when
> startup.pl has created database handle. This database handle gets cached
> and forked across child processes. With debugging turned on, there isn't
> "skipping connection during server startup, read the docu !!" message at
> all. It appears this new version only works with Apache2 but not Apache1.
> Is that possible to fix it with Apache1?
>
>  Thanks,
> - xinhuan
>
>   From: Perrin Harkins <pharkins@gmail.com>
> Date: Wednesday, June 12, 2013 5:53 AM
> To: Fred Moyer <fred@redhotpenguin.com>
> Cc: Xinhuan Zheng <xzheng@christianbook.com>, "modperl@perl.apache.org" <
> modperl@perl.apache.org>
>
> Subject: Re: Apache::DBI "connection lost contact" error
>
>   Thanks Fred!
>
>
> On Wed, Jun 12, 2013 at 3:29 AM, Fred Moyer <fred@redhotpenguin.com>wrote:
>
>> Apache-DBI 1.12 was just pushed to CPAN with this update. Thanks for
>> the great work on the fix Perrin.
>>
>> On Thu, Jun 6, 2013 at 2:53 PM, Perrin Harkins <pharkins@gmail.com>
>> wrote:
>> > That's great!  I'll commit the patch and see about getting a new
>> release out
>> > to CPAN.
>> >
>> > - Perrin
>> >
>> >
>> > On Thu, Jun 6, 2013 at 5:02 PM, Xinhuan Zheng <xzheng@christianbook.com
>> >
>> > wrote:
>> >>
>> >> Hi Perrin,
>> >>
>> >> I did a testing with debugging. I don't see the "connection lost
>> contact"
>> >> error anymore. The patch looks good to me.
>> >>
>> >> Thanks,
>> >> - xinhuan
>> >>
>> >> From: Perrin Harkins <pharkins@gmail.com>
>> >> Date: Thursday, June 6, 2013 3:02 PM
>> >> To: Xinhuan Zheng <xzheng@christianbook.com>
>> >> Cc: "modperl@perl.apache.org" <modperl@perl.apache.org>
>> >>
>> >> Subject: Re: Apache::DBI "connection lost contact" error
>> >>
>> >> On Thu, Jun 6, 2013 at 12:22 PM, Xinhuan Zheng <
>> xzheng@christianbook.com>
>> >> wrote:
>> >> > The database handle that is created in startup.pl needs to be really
>> >> > disconnected (not overloaded disconnect) so that won't leave an idle
>> server
>> >> > process running on the database side. Once it's really disconnected,
>> the
>> >> > server process can be cleaned up on the server side.
>> >>
>> >> Right, that's what the bug is preventing.
>> >>
>> >> Because my flight was delayed last night, I had time to make a patch.
>> >> Please try this on your system and send the debug, like you did before.
>> >>
>> >> - Perrin
>> >>
>> >
>>
>
>

Mime
View raw message