perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rommel Sharma <rsharm...@sapient.com>
Subject RE: mod_perl install error (build perl with -Dusethreads)
Date Thu, 20 Jun 2013 14:32:07 GMT
All,

The issue got resolved after I used the following options and rebuilt Perl.

In the folder where perl .gz file was uncompressed:

-          make distclean
-          CFLAGS='-m64 -mtune=nocona'
-          ./Configure -Dusethreads -Dprefix=/install/perl/v5.18 -des -A ccflags=-fPIC

Verified using:

/install/perl/v5.18/bin/perl -V:useithreads -V:usemultiplicity

Result should be like:

useithreads='define';
usemultiplicity='define';


I also upgraded mod_perl to 2.0.8 to get over another error message that is discussed here:
http://comments.gmane.org/gmane.os.netbsd.devel.pkgsrc.user/18165

(I've corrected the perl location in my previous mail that was due to a typo).

It works fine now, thanks.
Rommel.



From: Rommel Sharma [mailto:rsharma51@sapient.com]
Sent: Wednesday, June 19, 2013 4:55 PM
To: modperl@perl.apache.org
Subject: mod_perl install error (build perl with -Dusethreads)

Hi All,

I have Apache/2.2.22 and Perl/v5.18.0 and setting up mod_perl/2.0.7.

While installing mod_perl I am getting the following error:


Ø  file /install/perl/v5.18/bin/perl
gives
/install/perl/v5.18/bin/perl: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for
GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

Ø  Command to build mod_perl:
/install/perl/v5.18/bin/perl Makefile.PL MP_APXS=/export/apache/bin/apxs

Ø  Result:
Reading Makefile.PL args from @ARGV
   MP_APXS = /export/apache/bin/apxs
no conflicting prior mod_perl version found - good.
Configuring Apache/2.2.22 mod_perl/2.0.7 Perl/v5.18.0
[  error] Using Perl 5.018000 w/o ithreads and 'worker' mpm httpd.
[  error] Failed requirements:
[  error]   - Perl built with ithreads (build perl with -Dusethreads)

As recommended in the last line - "build perl with -Dusethreads" I tried that while setting
up perl but the same error.

Please share your inputs to resolve this.

Thanks,
Rommel.

Mime
View raw message