perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nageswara rao Gurram <nageshgurra...@gmail.com>
Subject Re: Net::SAML2 Compilation Error
Date Mon, 27 May 2013 12:37:38 GMT
By digging further, I found these details:

My mod_perl simply can't load XML::Generator. As soon as I put "use
XML::Generator;" in a perl startup file and include in httpd.conf,
Apache won't start, complaining that it can't locate
XML/Generator/overload.pm in @INC.

But the package XML::Generator::overload is in the same file as
XML/Generator.pm. Furthermore, when I go through the commandline (say
"perl -d -MXML::Generator -e 1"), all is fine.

And when I delete Apache2::porting.pm module from conf file, apache
starting fine.


On Mon, May 27, 2013 at 2:39 PM, Nageswara rao Gurram
<nageshgurram12@gmail.com> wrote:
> Hi,
>    I Installed new Module Net::SAML2 and all its dependencies. But
> when I try to use it, I am getting Compilation error.
>  I put 'use Net::SAML2' in my other module which causes the error, and
> also I verified it INC path too, it exists.
> More Info on error:
>
> [Mon May 27 11:36:34 2013] [error] [16474]ERR:  24:  Error in Perl
> code: Attempt to reload ftd_indices.pm aborted.\nCompilation failed in
> require at /usr/local/perl-5.14/lib/site_perl/5.14.2/x86_64-linux/Apache2/porting.pm
> line 90.\nBEGIN failed--compilation aborted
> Please help, I am trying from past two days.
>
> Thanks,
> Nageswara Rao G.

Mime
View raw message