perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Faust" <>
Subject Help on debugging print problem
Date Thu, 30 May 2013 11:11:36 GMT


I have some code I use all the time I use to download a file:


if (-e '/report.pdf') {

                open(PDF, '/report.pdf') or die "could not open PDF $!";

                binmode PDF;

                my $output = do { local $/; <PDF> };



                $r->err_headers_out->add('Content-Disposition' =>
'attachment; filename="report.pdf"');




I've never had a problem before using the above until trying to do it on a
new machine. On that machine every time I still get prompted to download the
file but FF/IE says its only 20 bytes (even though the pdf is 200k on the
file system) and what is downloaded is not what is on the filesystem.


I tried different files, different paths etc with the same results so I
don't think it's a location or permissions issue.


The only thing that gets logged in the attempt is:


TIGHT LOOP!!!: Apache2::RequestRec=SCALAR(0x47e2f78) can't


Any ideas how I could further debug that error to find the cause?






View raw message