perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tørmoen Joakim <Joakim.Torm...@evry.com>
Subject libapreq2 + META.yml not compliant with the CPAN meta spec
Date Mon, 29 Apr 2013 11:21:03 GMT
Hi,

I'm currently trying to add libapreq2 to a local pinto mirror, and I am having some problems
with that the content of the META.yml files is not compliant with the CPAN meta spec v.1.2

Unable to extract packages from libapreq2-2.13.tar.gz: Failed to upconvert metadata to 1.2.
Errors:
Missing mandatory field, 'file' (provides -> APR::Request::CGI -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> APR::Request::Error -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> Apache2::Request -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> APR::Request::Param -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> APR::Request::Cookie -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> Apache2::Upload -> file) [Validation: 1.2]
Missing mandatory field, 'file' (provides -> APR::Request -> file) [Validation: 1.2]
Missing mandatory field, 'file' (provides -> APR::Request::Apache2 -> file) [Validation:
1.2]
Missing mandatory field, 'file' (provides -> Apache2::Cookie -> file) [Validation: 1.2]


According to the CPAN meta spec the provides attribute must have a file key if it is present
( http://search.cpan.org/~dagolden/CPAN-Meta-2.130880/lib/CPAN/Meta/Spec.pm#provides ).

I would assume that the META.yml file should be something like this:

provides:
  Apache2::Request:
    version: 2.13
    file: glue/perl/lib/Apache2/Request.pm
  Apache2::Cookie:
    version: 2.13
    file: glue/perl/lib/Apache2/Cookie.pm
  Apache2::Upload:
    version: 2.13
    file: glue/perl/lib/Apache/Upload.pm
  APR::Request:
    version: 2.13
  APR::Request::Apache2:
    version: 2.13
  APR::Request::CGI:
    version: 2.13
  APR::Request::Error:
    version: 2.13
  APR::Request::Cookie:
    version: 2.13
  APR::Request::Param:
    version: 2.13

Could anyone advice me on where to point the file key for the rest of the packages? Has anyone
else experienced problems because the meta.yml file does not apply with the CPAN meta spec?

Best regards
Joakim
Mime
View raw message