perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jie Gao <J....@sydney.edu.au>
Subject Re: mod_perl resulting Apache failure
Date Tue, 05 Feb 2013 09:34:12 GMT
Hi Jitendra

You may send a bug report per http://perl.apache.org/docs/2.0/user/help/help.html#Reporting_Problems
.


Regards,

Jie Gao | Systems Administrator
Information and Communications Technology 

THE UNIVERSITY OF SYDNEY
316 Abercrombie Street Building G17 | The University of Sydney | NSW | 2006

T +61 2 8627 7824 | E j.gao@sydney.edu.au | W http://sydney.edu.au/ict/ 

CRICOS 00026A
This email plus any attachments to it are confidential. Any unauthorised
use is strictly prohibited. If you receive this email in error, please
delete it and any attachments. 

Please think of our environment and only print this e-mail if necessary.

* jitendra.soni@accenture.com <jitendra.soni@accenture.com> wrote:

> Date: Tue, 5 Feb 2013 08:59:20 +0000
> From: jitendra.soni@accenture.com
> To: jitendra.soni@accenture.com, J.Gao@sydney.edu.au
> CC: modperl@perl.apache.org
> Subject: RE: mod_perl resulting Apache failure
> 
> Hi Gao,
> 
> Can you please help in fixing this issue, its critical for my project. Below is the error
Iam getting on make test of mod_perl 2.0.7.
> 
> [soni498@sz1061:NODB mod_perl-2.0.7]$ make test
> cd "src/modules/perl" && make
> /usr/local/bin/perl -Iblib/arch -Iblib/lib \
> t/TEST -clean
> [warning] Skipping 'set unlimited ulimit for coredumps', since we are running as a non-root
user on Solaris
> APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= APACHE_TEST_USER= APACHE_TEST_APXS=
\
> /usr/local/bin/perl -Iblib/arch -Iblib/lib \
> t/TEST -bugreport -verbose=0 
> [warning] Skipping 'set unlimited ulimit for coredumps', since we are running as a non-root
user on Solaris
> /usr/httpd2.2.20/httpd/bin/httpd  -d /home/soni498/mod_perl-2.0.7/t -f /home/soni498/mod_perl-2.0.7/t/conf/httpd.conf
-D APACHE2 -D PERL_USEITHREADS
> using Apache/2.2.20 (prefork MPM)
> 
> waiting 120 seconds for server to start: .........................................................................................................................
> waiting 120 seconds for server to start: not ok
> [  error] giving up after 121 secs. If you think that your system
> is slow or overloaded try again with a longer timeout value.
> by setting the environment variable APACHE_TEST_STARTUP_TIMEOUT
> to a high value (e.g. 420) and repeat the last command.
> 
> [  error] server failed to start! (t/logs/error_log wasn't created, start the server
in the debug mode)
> +--------------------------------------------------------+
> | Please file a bug report: http://perl.apache.org/bugs/ |
> +--------------------------------------------------------+
> *** Error code 1
> make: Fatal error: Command failed for target `run_tests'
> [soni498@sz1061:NODB mod_perl-2.0.7]$
> 
> Thanks & Regards,
> -----------------------------------------------------
> Jitendra Soni
> Accenture, Bangalore INDIA
> Mailto: jitendra.soni@accenture.com
> Phone: (+91) 99860 29897
> 
> -----Original Message-----
> From: Soni, Jitendra 
> Sent: Thursday, January 24, 2013 12:58 PM
> To: 'Jie Gao'
> Cc: modperl@perl.apache.org
> Subject: RE: mod_perl resulting Apache failure
> 
> Perl ->> sh Configure -de -Dcc=gcc
> Apache ->> ./configure --prefix=/usr/apache02/httpd2.2.20/
> 
> Thanks & Regards,
> -----------------------------------------------------
> Jitendra Soni
> Accenture, Bangalore INDIA
> Mailto: jitendra.soni@accenture.com
> Phone: (+91) 99860 29897
> 
> 
> -----Original Message-----
> From: Jie Gao [mailto:J.Gao@sydney.edu.au] 
> Sent: Thursday, January 24, 2013 12:34 PM
> To: Soni, Jitendra
> Cc: modperl@perl.apache.org
> Subject: Re: mod_perl resulting Apache failure
> 
> What are the flags you used to compile apache and perl (perl -V) ?
> 
> Regards,
> 
> Jie Gao | Systems Administrator
> Information and Communications Technology 
> 
> THE UNIVERSITY OF SYDNEY
> 316 Abercrombie Street Building G17 | The University of Sydney | NSW | 2006
> 
> T +61 2 8627 7824 | E j.gao@sydney.edu.au | W http://sydney.edu.au/ict/ 
> 
> CRICOS 00026A
> This email plus any attachments to it are confidential. Any unauthorised use is strictly
prohibited. If you receive this email in error, please delete it and any attachments. 
> 
> Please think of our environment and only print this e-mail if necessary.
> 
> * jitendra.soni@accenture.com <jitendra.soni@accenture.com> wrote:
> 
> > Date: Thu, 24 Jan 2013 06:48:22 +0000
> > From: jitendra.soni@accenture.com
> > To: J.Gao@sydney.edu.au
> > CC: modperl@perl.apache.org
> > Subject: RE: mod_perl resulting Apache failure
> > 
> > HI Jie,
> > 
> > We are not using Solaris installed Apache and GCC complier.
> > 
> > Thanks & Regards,
> > -----------------------------------------------------
> > Jitendra Soni
> > Accenture, Bangalore INDIA
> > Mailto: jitendra.soni@accenture.com
> > Phone: (+91) 99860 29897
> > 
> > -----Original Message-----
> > From: Jie Gao [mailto:J.Gao@sydney.edu.au]
> > Sent: Thursday, January 24, 2013 5:25 AM
> > To: Soni, Jitendra
> > Cc: modperl@perl.apache.org
> > Subject: Re: mod_perl resulting Apache failure
> > 
> > You seem to have more than 1 issue here.
> > 
> > First of all, are you using the Apache that comes installed with Solaris?
> > 
> > And what compiler did you use?
> > 
> > Regards,
> > 
> > Jie
> > 
> > * jitendra.soni@accenture.com <jitendra.soni@accenture.com> wrote:
> > 
> > > Date: Sat, 19 Jan 2013 15:15:27 +0000
> > > From: jitendra.soni@accenture.com
> > > To: modperl@perl.apache.org
> > > Subject: mod_perl resulting Apache failure
> > > 
> > > Hi Team,
> > > 
> > > I am installing Apache Mobile Filter on solaris 5.10 but after installing mod_perl,
Apache restart is failing. Below are steps executed by me:
> > > 
> > > (1) Solaris 5.10 Sparx 64
> > > (2) Installed perl 5.14.2
> > > (3) Installed mod_perl 2.0.5
> > > (4) Included mod_perl module in Apache httpd.conf ( iam using apache 2.2.20).
> > > (5) Restarted Apache - FAILED - by error - Segmentation Fault (Core Dumped).
> > > 
> > > Can someone let me know did I missed anything during installation or what can
I do to fix this issue and make this work for me.
> > > 
> > > Thanks in advance. I will greatly appreciate if you guys can help in fixing
the issue as this is very critical for our project.
> > > 
> > > Regards,
> > > Jitendra
> > > 
> > > ________________________________
> > > This message is for the designated recipient only and may contain privileged,
proprietary, or otherwise private information. If you have received it in error, please notify
the sender immediately and delete the original. Any other use of the e-mail by you is prohibited.
> > > 
> > > Where allowed by local law, electronic communications with Accenture and its
affiliates, including e-mail and instant messaging (including content), may be scanned by
our systems for the purposes of information security and assessment of internal compliance
with Accenture policy.
> > > 
> > > ____________________________________________________________________
> > > __________________
> > > 
> > > www.accenture.com
> > 
> > 
> 
> 

Mime
View raw message