I'm using Interchange::Link for linking mod_perl to Interchange (icdevgroup.org).  It works with 2.0.4 but breaks with 2.0.7.  Someone told me they tracked it down to line 684:

while( <SOCK> ) {

https://github.com/interchange/interchange/blob/master/dist/src/mod_perl2/Interchange/Link.pm

I know this isn't much to go on, but were there any changes between those versions that are a likely candidate?

- Grant