perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Re: Build error, requiring threads when threads are not built in
Date Fri, 13 Jul 2012 00:35:57 GMT
Apache 2.4 support hasn't been added yet, so I'm guessing that may
have contributed to this build failure. You may want to try with just
the MP_APXS build arguments though.

On Thu, Jul 12, 2012 at 2:46 PM, Susan <susan@buczak.us> wrote:
> I keep getting this error trying to build the dso mod_perl2 with apache2.
> Httpd was built with mpm-prefork, perl was not compiled with threads. below
> are configure options.
>
> this is the build error with the configure options:
>
> root [ ~/.cpan/build/mod_perl-2.0.7-gdtpWS ]# perl Makefile.PL
> MP_APXS=/usr/bin/apxs MP_APR_CONFIG=/usr/bin/apr-1-config \
>> MP_USE_DSO=1 MP_AP_CONFIGURE="--with-mpm=prefork"
> Reading Makefile.PL args from @ARGV
>    MP_APXS = /usr/bin/apxs
>    MP_APR_CONFIG = /usr/bin/apr-1-config
>    MP_USE_DSO = 1
>    MP_AP_CONFIGURE = --with-mpm=prefork
> no conflicting prior mod_perl version found - good.
> Configuring Apache/2.4.2 mod_perl/2.0.7 Perl/v5.14.2
> [  error] Using Perl 5.014002 w/o ithreads and 'dynamic' mpm httpd.
> [  error] Failed requirements:
> [  error]   - Perl built with ithreads (build perl with -Dusethreads)
>
>
> --------
>
> this is config info from apache and perl:
>
> root [ ~/.cpan/build/mod_perl-2.0.7-gdtsWQ ]# httpd -V
> Server version: Apache/2.4.2 (Unix)
> Server loaded:  APR 1.4.6, APR-UTIL 1.4.1
> Compiled using: APR 1.4.6, APR-UTIL 1.4.1
> Architecture:   32-bit
> Server MPM:     prefork
>   threaded:     no
>     forked:     yes (variable process count)
>
>
>
> root [ ~/.cpan/build/mod_perl-2.0.7-gdtsWQ ]# perl -V
> Summary of my perl5 (revision 5 version 14 subversion 2) configuration:
>
>   Platform:
>     osname=linux, osvers=3.2.15, archname=i686-linux
>     uname='linux c5 3.2.15 #0 smp sat apr 28 12:52:13 edt 2012 i686 gnulinux
> '
>     config_args='-des  -isR -Duseshrplib'
>     hint=recommended, useposix=true, d_sigaction=define
>     useithreads=undef, usemultiplicity=undef
>     useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
>     use64bitint=undef, use64bitall=undef, uselongdouble=undef
>     usemymalloc=n, bincompat5005=undef
>
>
>
> ---
>
> any help would be appreciated. I do not want threads compiled into perl.
>
> Susan
>
> Message 1 of 90
>

Mime
View raw message