perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Narins <jnar...@seniorbridge.com>
Subject RE: mod_perl segfaults, can't start Apache
Date Mon, 25 Jun 2012 17:05:36 GMT
I always like to start with strace and running the httpd in debug mode (one child) with -X.




Josh Narins
Director of Application Development
SeniorBridge

845 Third Ave
7th Floor
New York, NY 10022
Tel: (212) 994-6194
Fax: (212) 994-4260
Mobile: (917) 488-6248
jnarins@seniorbridge.com
seniorbridge.com<http://www.seniorbridge.com/>

[http://www.seniorbridge.com/images/seniorbridgedisclaimerTAG.gif]


________________________________
SeniorBridge Statement of Confidentiality: The contents of this email message are intended
for the exclusive use of the addressee(s) and may contain confidential or privileged information.
Any dissemination, distribution or copying of this email by an unintended or mistaken recipient
is strictly prohibited. In said event, kindly reply to the sender and destroy all entries
of this message and any attachments from your system. Thank you.
From: John Manko [mailto:john.manko@gmail.com]
Sent: Monday, June 25, 2012 12:58 PM
To: modperl@perl.apache.org
Subject: mod_perl segfaults, can't start Apache

mod_perl is failing with Apache, and I'm having trouble figuring out why.  I'm running under
Gentoo.

mod_perl version 2.0.7
apache version 2.2.22-r1, build with threads and worker MPM
libperl version 5.10.1-r1
perl version 5.16.0 with ithreads support


# /etc/init.d/apache2 start
 * Starting apache2 ...
 * start-stop-daemon: failed to start `/usr/sbin/apache2'

# dmesg
apache2[12697]: segfault at c ip b5d4974a sp bffce4d0 error 4 in mod_perl.so[b5d24000+45000]

Any ideas on what to look for to determine the problem?

Mime
View raw message