perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "cfaust-dougot" <cfa...@doyougot.com>
Subject Apache::Reload
Date Sun, 17 Jun 2012 12:23:50 GMT
Hello,
I'm having a problem with Apache::Reload and I'm not sure what I can do to debug.

Long story short, I use Apache::Reload all the time but I recently setup a new development
server and its under the new machine that its a problem.
 
The module is installed and when I add to my conf:
 
  PerlInitHandler Apache::Reload
  PerlSetVar ReloadAll Off
 
I can restart apache and everything loads up (apache starts and will serve static pages etc).
The problem happens as soon as you invoke a mod_perl content handler. The first time you hit
a script URL you get a 500 internal server error, but as soon as you comment out those 2 lines
everything works (except apache reload of course).
 
What is killing me is there is NOTHING logged!!! The apache log and domain logs show nothing.
 
This server is a WHM/CPANEL server and I'm wondering if that has anything to do with it? I
don't know if its just a coincidence, but on every non-cpanel machine I have ever seen has
"apache reload", but on the cpanel machines its "apache graceful". I wouldn't think that should
matter but the timing is there because the module does load via the conf but the first time
you invoke a mod_perl content handler, Apache::Reload should be tell apache to reload its
configs and that's when you get the 500 error.
 
My install is old because I'm trying to stay within the available repositores instead of building
from source, I guess I could update but I don't know if that's going to solved my problem.
 
CentOS 5.8
Apache/2.2.22 (Unix) 
mod_apreq2-20090110/2.8.0 
mod_perl/2.0.5 
Perl/v5.8.8 
 
Any ideas of how I can debug this? I can't believe that apache is throwing a 500 error and
no information about it is being logged, that at least might tell me something.
 
TIA!
-Chris
 

Mime
View raw message