perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Pettyjohn <bruce.pettyj...@gmail.com>
Subject [mp2] Configure fails w/Perl 5.16.0
Date Mon, 04 Jun 2012 18:01:53 GMT
Thanks for any help in resolving this bug.  I have been using mod_perl for
years and been happy.  I would like to take advantage of the new Apache and
need mod_perl to be part of it.

 

Cheers,

 

Bruce Pettyjohn

 

 

-------------8<---------- Start Bug Report ------------8<----------

1. Problem Description:

 

 

I am trying to configure with Apache 2.4.2, mp 2.0.6 and Perl 5.16.0 with no
luck. 

 

Perl was compiled with and without threads.

 

$ ./Configure -des -Dusethreads

$ ./Configure -des -Uusethreads

 

Apache 2.4.2 was compiled with

 

$ ./configure --prefix=/usr/local/apache2/httpd/prefork \

--with-mpm=prefork \

--enable-mods-shared=all \

--with-included-apr \

--with-perl=/usr/local/perl \

--enable-ssl --enable-so

 

The latest patch for modperl_perl.c was applied and the make process stops
prematurely with this error note.

 

 

root@dev2 downloads]# cd mod_perl-2.0.6

[root@dev2 mod_perl-2.0.6]# perl Makefile.PL
MP_APXS=/usr/local/apache2/httpd/prefork/bin/apxs
MP_APR_CONFIG=/usr/local/apr/bin/apu-1-config

Reading Makefile.PL args from @ARGV

   MP_APXS = /usr/local/apache2/httpd/prefork/bin/apxs

   MP_APR_CONFIG = /usr/local/apr/bin/apu-1-config

no conflicting prior mod_perl version found - good.

Configuring Apache/2.4.2 mod_perl/2.0.7 Perl/v5.16.0

[  error] Using Perl 5.016000 w/o ithreads and 'dynamic' mpm httpd.

[  error] Failed requirements:

[  error]   - Perl built with ithreads (build perl with -Dusethreads)

 

The error_log file (t/logs/error_log) is non-existent.  The "logs" directory
is missing in this distribution.  After adding the "logs" directory the
"error_log" file was not created. 

 

 

 

 

2. Used Components and their Configuration:

 

*** mod_perl version 2.000006

 

*** using /var/downloads/mod_perl-2.0.6/lib/Apache2/BuildConfig.pm

 

*** Makefile.PL options:

  MP_APR_CONFIG  => /usr/local/apr/bin/apu-1-config

  MP_APR_LIB     => aprext

  MP_APXS        => /usr/local/apache2/httpd/prefork/bin/apxs

  MP_COMPAT_1X   => 1

  MP_GENERATE_XS => 1

  MP_LIBNAME     => mod_perl

  MP_USE_DSO     => 1

 

 

*** The httpd binary was not found

 

 

*** (apr|apu)-config linking info

 

 -L/usr/local/apr/lib -laprutil-1     -lexpat 

 

 

 

***  -V

 

*** Packages of interest status:

 

Apache2            : -

Apache2::Request   : -

CGI                : 3.59

ExtUtils::MakeMaker: 6.63_02

LWP                : 5.834, 6.04, 6.04

mod_perl           : -

mod_perl2          : -

 

 

3. This is the core dump trace: (if you get a core dump):

 

  [CORE TRACE COMES HERE]

 

None

 

 

This report was generated by t/REPORT on Mon Jun  4 17:35:24 2012 GMT.

 

-------------8<---------- End Bug Report --------------8<----------

 

 

 

 

 

 

 

 

 

 

 


Mime
View raw message