perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@redhotpenguin.com>
Subject Re: Installing mod_perl for 2 versions of Perl?
Date Mon, 11 Jul 2011 19:41:59 GMT
On Mon, Jul 11, 2011 at 12:38 PM, Perrin Harkins <perrin@elem.com> wrote:
> On Mon, Jul 11, 2011 at 3:14 PM, Octavian Rasnita <orasnita@gmail.com> wrote:
>> From: "Perrin Harkins" <perrin@elem.com>
>> I am still afraid to compile Perl+Apache+mod_perl since the old days when I needed
to do that because there were no other solutions, and when I needed to face some ugly compiling
errors...
>>
>> But if you say that it is simple, I will try it.
>
> I know some people have issues but I've never had any on common Linux
> platforms.  It complies very nicely.  Just be sure to use the perl you
> want to compile against when running Makefile.PL for mod_perl.

and the desired apxs binary with:

    /my/perl Makefile.PL MP_APXS=/my/apxs

By default version 2.0.5 will look for installed apxs/apxs2 binaries
in certain places like your PATH and use those by default if you don't
explicitly specify which apxs binary to use.

Mime
View raw message