perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tosh Cooey <t...@1200group.com>
Subject Re: Re: Debugging a long process
Date Wed, 15 Jun 2011 20:29:35 GMT
Hi Fred, I like the idea of "Apache may be blocking on other processes" 
but the Devel::NYTProf docs don't seem to indicate if it would be 
helpful in tracking down the reason for a 30 second execution under 
mod_perl versus a 9 second execution from the shell.  Also there seems 
to be some issues WRT Devel::NYTProf and virtual machines, which I 
believe my EC2 instance is one of.

Is there anywhere to point me to find out more about the blocking issue 
and how to resolve it?

Thanks!

Tosh


On 7/22/64 8:59 PM, Fred Moyer wrote:
> On Wed, Jun 8, 2011 at 12:50 PM, Tosh Cooey<tosh@1200group.com>  wrote:
>> I have a mod_perl Registry script that is taking about 30 seconds to
>> execute.
>>
>> I am trying to debug it but when I run the script from the command line or
>> the debugger it only takes 9 seconds to execute.
>
> Sounds like Apache may be blocking on other processes?  Have you tried
> Devel::NYTProf with your program on the command line?
>
>>
>> I am running Apache/2.2.11 (Ubuntu) mod_perl/2.0.4 Perl/v5.10.0
>>
>> Is there something obvious I should be looking at, and does anyone have any
>> tips for debugging something like this?
>>
>> Thanks!
>>
>> Tosh
>>
>> --
>> McIntosh Cooey - Twelve Hundred Group LLC - http://www.1200group.com/
>>
>

-- 
McIntosh Cooey - Twelve Hundred Group LLC - http://www.1200group.com/

Mime
View raw message