perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Bulley <...@umich.edu>
Subject Re: apache2 or mod_perl2 oddball error
Date Thu, 16 Jun 2011 18:54:21 GMT
According to Fred Moyer <fred@redhotpenguin.com> on Thu, 06/16/11 at 13:56:
> 
> Hmm, odd that it wouldn't work under 2.0.5 but it would under 2.0.4.

My point exactly...   :-(

> No idea why offhand.  Do you use a startup.pl in your application?

No.  The application's URL points to a directory with Mason laden HTML
files starting with "index.html".  Why do you ask?

> > Neither of these two commands gave any output at all:
> >
> > ? freebsd% perl -e 'use Apache2::Const qw( :common );
> > ? freebsd% perl -M'Apache2::Const -compile => qw(:common)' -e 1;
> 
> You need to call these statements in the context of a mod_perl interpreter.

Forgive me, but I don't understand what you mean.  :-(

Recall the error message:

freebsd# apachectl -t
[Thu Jun 16 14:29:15 2011] [error] syntax error at (eval 21) line 1, near "require Apache2::Const
-"\n
[Thu Jun 16 14:29:15 2011] [error] Can't load Perl module Apache2::Const -compile => ':common'
for server localhost, exiting...

I have just searched the entire application source hierarchy for the
string ":common" using the find(1) command.  The only file that contains
that string is the apache Includes file which has not changed since my
system upgrade.  Here are several of the lines in that file:

   #begining of file
   PerlModule ModPerl::Util
   PerlModule Apache2::Request
   PerlModule Apache2::RequestRec
   PerlModule Apache2::RequestIO
   PerlModule Apache2::RequestUtil
   PerlModule Apache2::ServerUtil
   PerlModule Apache2::Connection
   PerlModule Apache2::Log
   PerlModule Apache::Session
   PerlModule APR::Table
   PerlModule ModPerl::Registry
   PerlModule "Apache2::Const -compile => ':common'"      <<<<<<=======
   PerlModule "APR::Const -compile => ':common'"          <<<<<<=======

   PerlModule Apache2::SiteControl
   PerlModule HTML::Mason::ApacheHandler

   # Uncomment this next line if you get errors from libapreq2
   # about an 'undefined symbol'
   # LoadModule apreq_module /usr/lib/apache2/modules/mod_apreq2.so
   LoadModule apreq_module /usr/local/libexec/apache22/mod_apreq2.so
   .
   .
   .

Later in this file (and elsewhere in the application) there are uses of,
and references to, Apache2::Const, but there are no references to the
APR::Const module.  I have tried commenting these lines out and tried
removing the trailing parameters.  In some of the many permutations of
these two lines, I get a successful parsing of the httpd.conf file, but
likely that is because I commented out the entire line.  However, in
these cases, I get a dozen error lines like this one:

   Attempt to free unreferenced scalar: SV 0x28bda050 during global destruction.

In no case do I get a successful launch of the apache server, nor do
I get any lines in the httpd_error.log file.  Any other ideas?

Regards,

web...

--
William Bulley                     Email: web@umich.edu

72 characters width template ----------------------------------------->|

Mime
View raw message