perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szekeres, Edward" <Edward.Szeke...@PERKINELMER.COM>
Subject FW: Installation help [mod_perl 2.0.5/apache 2.2.17/perl-5.12.3]
Date Mon, 18 Apr 2011 20:48:03 GMT

Wanted to let you know I accidently stumbled on a something that worked,  I had noticed that
if I ran the mod_perl config twice, the second time it ran it would not show that apr directory-not-found
error, however the make would fail with some APR related errors,  however,  if I added the
"--with-included-apr" option to the MP_AP_CONFIGURE option to the mod_perl config, then again
ran the command twice, the first time it would fail with the directory not found error as
before, the second time it ran through completely, *BUT* this time 'make' ran without a problem
and the rest of the process ran error free.  I then checked with 'httpd -l' and mod_perl.c
was listed in the built in module list.  I am trying to test the now running web service
to see if everything functions.

Not quite sure what that all meant....but it seems I now have a static  linked version

> -----Original Message-----
> From: Fred Moyer []
> Sent: Monday, April 18, 2011 2:44 PM
> To: Szekeres, Edward
> Cc:
> Subject: Re: Installation help [mod_perl 2.0.5/apache 
> 2.2.17/perl-5.12.3]
> On Mon, Apr 18, 2011 at 9:46 AM, Szekeres, Edward <>
>> Thanks for your reply....clarifications
> For what it is worth, I'd suggest building mp2 as a shared object; this approach is very
well tested.  You may be able to build as a static module, but that can take some additional
effort, and that build option is not as widely tested.
> Building as a dso is simple - 'perl Makefile.PL MP_APXS=/usr/local/bin/apxs', or just
'perl Makefile.PL' if your apxs is in $ENV{PATH}.  This requires that you build Apache outside
the mod_perl build, but for that I usually './configure --enable-so --with-included-apr --prefix=/path/to/my/apache'.
>> 1) Perl 5.12.3 was compiled without thread support as per the 
>> mod_perl
>> 2.0 installation directions
>> 2) I have tried adding the "--with-included-apr" option without luck
>> 2) As per the mod_perl documentation for static I am not 
>> pre-compiling Apache but was allowing the mod_perl 2.0 process to 
>> handle that
>> 3) I  was trying to match a pre-existing configuration which was using Apache 1.3
with  mod_perl 1.0 statically linked in.  While it would be preferred to keep the configuration
the same, I am not sure it is mandatory.
>> 4) what is also interesting is if I repeat the mod_perl configuration command again,
I do not get that "Can't find apr include/ directory" error, and the config proceeds fine,
however the make just throws a bunch of errors which seem to be apr related...

View raw message