perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szekeres, Edward" <Edward.Szeke...@PERKINELMER.COM>
Subject Installation help [mod_perl 2.0.5/apache 2.2.17/perl-5.12.3]
Date Mon, 18 Apr 2011 15:30:22 GMT
Hello,

 

I am attempting to get a clean up-to-date install Apache with static
linked mod_perl (using  current stable releases for Apache (2.2.17) and
mod_perl (2.0.5) from .tar.gz files download from respective
repositories) but am at a frustrating dead end.  I am looking for any
suggestions as I have an immediate need for this.

 

Here are the steps I have taken (multiple times):

1)      configured a new RHEL 5 32 bit virtual machine with 2 CPUs and
4G RAM using "software development" template and no additional software
(no httpd), default PERL install of 5.8.8...

2)      all RHEL updates as of 4/17 applied

3)      download source for PERL 5.12.3, and installed

a.       # ./Configure -des -Uusethreads

b.      make, make test, make install  (no errors)

4)      installed from CPAN  "Bundle::Apache2" (tried both with and
without this step, # /usr/local/bin/perl5.12.3 -MCPAN -e "install
Bundle::Apache2")

5)      though was using the official  .tar.gz distribution of Apache, I
did run ./buildconf in the Apache source directory for consistency (no
errors)

6)      executed the mod_perl config in the mod_perl source directory: 
 # /usr/local/bin/perl5.12.3 Makefile.PL MP_USE_STATIC=1
MP_AP_PREFIX=/root/httpd-2.2.17  MP_AP_CONFIGURE="-with-mpm=prefork"

 

and this is always the result at the end, what is interesting is that in
all the previous config steps, there don't seem to be any issues in
finding and working with apr related stuff....

 

Configuring Apache/2.2.17 mod_perl/2.0.5 Perl/v5.12.3

Checking if your kit is complete...

Looks good

Use of uninitialized value $v in substitution (s///) at
lib/Apache2/Build.pm line 1330.

[  error] Can't find apr include/ directory,

[  error] use MP_APR_CONFIG=/path/to/apr-config

(END) 

 

Thinking there was maybe a conflict with RHEL apr I did try running #
yum remove apr* to remove RHEL related packages....

 

repeated the whole process same result....same results with Perl 5.8.8

 

I really can't believe that virgin stable release TARs on a pretty much
standard RHEL 5 installs would be this difficult to get to work.  

 

Any help would be greatly appreciated....

 

 

 

 

 

Edward S. Szekeres, Jr., Ph.D. | Director of Bioinformatics

PerkinElmer DNA Sequencing and Analysis Services
PerkinElmer | For the Better


edward.szekeres@perkinelmer.com
<mailto:edward.szekeres@perkinelmer.com?subject=Contact%20Request> 

Phone:  +1 203.433.3237   |   Fax:  +1 203.481.0433   |   Mobile:   +1
203.738.9524

29 Business Park Drive, Branford, CT 06405 USA 

www.perkinelmer.com <http://www.perkinelmer.com/> 

 

Please consider the environment before printing this e-mail.

This e-mail message and any attachments are confidential and proprietary
to PerkinElmer, Inc.  If you are not the intended recipient of this
message, please inform the sender by replying to this email or sending a
message to the sender and destroy the message and any attachments.
Thank you.

 

 

 


Mime
View raw message