perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From deepakarun <deepaka...@gmail.com>
Subject mod_perl.so compatiable issue
Date Mon, 21 Mar 2011 13:45:23 GMT

I am trying to install Bugzilla software in Apache Web Server. I am trying =
to use mod_perl option. The source I used is mod_perl-2.0.5-i35fJ9, I execu=
ted the following commands:
perl Makefile.PL MP_APXS=3D/usr/local/httpd-bugzilla/bin/apxs

make

make install

After install, it created the mod_perl.so under /usr/local/apache2/modules/= 
which is not my Apache HOME.

I copied the mod_perl.so file to my HOME /usr/local/httpd-bugzilla/modules =
and tried starting Apache and I got the following error:

# ./apachectl start
httpd: Syntax error on line 115 of /usr/local/httpd-bugzilla/conf/httpd.con=
f: API module structure 'perl_module' in file /usr/local/apache2/modules/mo=
d_perl.so is garbled - expected signature 41503232 but saw 41503230 - perha=
ps this is not an Apache module DSO, or was compiled for a different Apache= 
version?

Any help solving the above issue would be highly appreciated.

Thanks in advance,
Deepa

-- 
View this message in context: http://old.nabble.com/mod_perl.so-compatiable-issue-tp31200796p31200796.html
Sent from the mod_perl - General mailing list archive at Nabble.com.


Mime
View raw message