perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vanja Hrustic <vanja.hrus...@gmail.com>
Subject Re: mod_perl "instability" on Ubuntu 10.04 server platform
Date Thu, 28 Oct 2010 11:49:04 GMT
Tried on physical boxes on same LAN (Gigabit switch), virtual machines
(issuing requests from the same box where VBox is running - so no
switches involved, and also from other box on LAN), tried on colocated
boxes (those are Ubuntu - was issuing requests from one dedicated
server to another), etc.

Just did few million more requests with Debian, no problems. Did
10,000 with completely clean Ubuntu 64-bit 10.04 server setup, got 4
dead workers.

I will be going back to Debian for sure, but I kind of wanted to see
if I could possibly give some more useful bug description to Ubuntu
people, rather than "Hey, this doesn't work - fix it" ;)

Unfortunately, it seems like I'd have to dig deep into Apache or
mod_perl to hunt this down, and I do not have knowledge (nor
'intuition' :) to do this without some guidance.

Basically, if I end up with these unresponsive threads, is there
anything I can do to figure out what caused them to hang? Would gdb be
of any use, would I be able to attach to these threads and see any
useful details (never debugged threaded apps, so no idea how that
would work)?

Thanks.

Vanja

On Thu, Oct 28, 2010 at 6:35 PM, Cosimo Streppone <cosimo@streppone.it> wrote:
> On Thu, 28 Oct 2010 12:22:05 +0200, Vanja Hrustic <vanja.hrustic@gmail.com>
> wrote:
>
>> No matter what changes I made to the app, it was still failing. I
>> pretty much ended up returning from the application immediately after
>> invocation, but I would still end up with failed requests.
>
> Are the Debian 5 and Ubuntu 10.04 servers
> on different networks/switches?
>
> Did you try making requests from localhost
> or from your workstation?
>
> Sometimes a faulty or overloaded network switch can cause
> packet loss, and thus slow response times.
>
> --
> Cosimo
>

Mime
View raw message