perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Morten Bjørnsvik <morten.bjorns...@experian-da.no>
Subject unable to compile perl under perl 5.10.1
Date Mon, 11 Jan 2010 15:23:41 GMT
Hi all
I'm unable to compile mod_perl-2.0.x from svn(trunk 2.0.5-dev) or cpan(2.0.4) on perl 5.10.1,
do anyone have some
black belt options that make it works, I believed the -fPIC now is embedded in the -Dusethreads,
because
I see it appear lots of places in the perl compile output

I've tried compiling perl 5.10.1 with the following options

./Configure -des -A ccflags="-O2 -DPERL_USE_SAFE_PUTENV -fPIC" -Dusethreads -Duse64bitall
\
      -Dprefix=/opt/perl -Dinstallprefix=/opt/perl

./Configure -des -A ccflags=-DPERL_USE_SAFE_PUTENV -Accflags="-fPIC" -Dusethreads \
      -Duse64bitall -Dprefix=/opt/perl -Dinstallprefix=/opt/perl

./Configure -des -A -Dusethreads -Duse64bitall -Dinstallprefix=/opt/perl

perl always compiles and seem to work fine with other modules.

Mod_perl2.0 build:
Both cpan and and the svn checkout version, shows the same error:
build cmd: cd '/usr/tmp/cpan_extract/mod_perl-2.0'; /opt/perl/bin/perl Makefile.PL MP_APXS=/opt/apache/bin/apxs

cc -shared -O2 -L/usr/local/lib -fstack-protector \
         \
        mod_perl.lo modperl_interp.lo modperl_tipool.lo modperl_log.lo modperl_config.lo modperl_cmd.lo
modperl_options.lo modperl_callback.lo modperl_handler.lo modperl_gtop.lo modperl_util.lo
modperl_io.lo modperl_io_apache.lo modperl_filter.lo modperl_bucket.lo modperl_mgv.lo modperl_pcw.lo
modperl_global.lo modperl_env.lo modperl_cgi.lo modperl_perl.lo modperl_perl_global.lo modperl_perl_pp.lo
modperl_sys.lo modperl_module.lo modperl_svptr_table.lo modperl_const.lo modperl_constants.lo
modperl_apache_compat.lo modperl_error.lo modperl_debug.lo modperl_common_util.lo modperl_common_log.lo
modperl_hooks.lo modperl_directives.lo modperl_flags.lo modperl_xsinit.lo modperl_exports.lo
 -Wl,-E  -fstack-protector -L/usr/local/lib  -L/opt/perl/lib/5.10.1/x86_64-linux-thread-multi/CORE
-lperl -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc \
        -o mod_perl.so
/usr/bin/ld: /opt/perl/lib/5.10.1/x86_64-linux-thread-multi/CORE/libperl.a(op.o): relocation
R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile
with -fPIC
/opt/perl/lib/5.10.1/x86_64-linux-thread-multi/CORE/libperl.a: could not read symbols: Bad
value
collect2: ld returned 1 exit status
make[1]: *** [mod_perl.so] Error 1
make[1]: Leaving directory `/var/tmp/cpan_extract/mod_perl-2.0/src/modules/perl'
make: *** [modperl_lib] Error 2


Any ideas greatly appreciated.

Thanks
----------------------------------------------------------------
Morten Bjørnsvik, Experian Decision Analytics AS, Oslo, Norway
----------------------------------------------------------------



Mime
View raw message