perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 陈建春 <chen...@maxthon.net>
Subject Re: Apache Blank Pages
Date Wed, 13 Jan 2010 12:08:37 GMT
what is your apache's mpm? worker or prefork?

Our site sometimes also rise similar error(like glibc detected ... in 
error log ) under worker mpm.

*陈建春 | ChenJianchun*
傲游Web应用部
E-mail: chenjch@maxthon.net <mailto:chenjch@maxthon.net>

*Maxthon^® * --每个人的互联网中心!         上网从傲游开始!
傲游天下科技有限公司(中国) <http://www.maxthon.cn/> | www.maxthon.cn 
<http://www.maxthon.cn/>

*诚信、创新、务实、奋斗!*



cfaust-dougot 写道:
> Hello,
>  
> I have a bizarre problem I'm hoping someone could give me some 
> suggestions with.
>  
> I have a couple of MP2 scripts running on a server, they are both 
> similar in use of modules and structure. Without any recent changes, 
> one of the scripts is producing a blank apache page on SOME requests.
>  
> It's not always the same function, it can happen to any of the 
> function calls contained in the script.
>  
> When the blank page happens there is nothing in either the access log 
> or the error log of that virtual host (like the request never made it 
> that far).
>  
> In the default error log I will get something like
>  
> [notice] child pid 11497 exit signal Aborted (6)
>  
> Sometimes (but not always), I'll see
>  
> *** glibc detected *** malloc(): memory corruption: 0x09c120f8 ***
>  
> There is also no consistency to the blank page, sometimes you hit the 
> URL and you get the content, sometimes you get a blank page, sometimes 
> 1 refresh on the blank page gives you content, other times it can take 
> 3 - 7 refreshes before the content comes.
>  
> I've been trying to pull apart my script piece by piece in the hopes 
> that I could at least narrow it down to some specific section but I'm 
> not having a lot of luck.
>  
> Any thoughts on how I could debug this better?
>  
> TIA!

Mime
View raw message