perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Installing under Cygwin?
Date Mon, 28 Dec 2009 11:38:37 GMT
Sorry, I hit the send button too quickly.
I meant to send this to the list, not to you personally.

Octavian Râşniţă wrote:
> Hi,
> 
> Does anyone know if mod_perl can be installed under Cygwin?
> 
> I have tried to install it with cpan, but it gave an error on the `make` 
> step.
> 
I cannot answer your question directly, I don't know.

But my question is : why would you want to do that ?

One of the beauties of Perl, is that it runs on multiple platforms,
Windows native being one of them.
And so does Apache 2.x.
And so does mod_perl, in combination of Apache 2.x for Windows, and
ActivePerl from www.activestate.com.

And unless your scripts or mod_perl handlers really need to do something
that is OS-specific, they should not need to be changed to run under the
above combination.

There are good instructions of how to install this on the mod_perl site.
If you have any problem, get back here and someone will help.



Mime
View raw message