perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "R.Polonski" <rpolon...@googlemail.com>
Subject [mp2] OS X snow leopard compile issue
Date Mon, 23 Nov 2009 22:45:04 GMT
Hello,

I tried to compile mod_perl 2.0.4 on mac os x 10.6.2

httpd 2.2.14
./configure --prefix=/tmp/q
make ; make install

mod_perl 2.0.4 and latest from SVN
perl Makefile.PL MP_APXS=/tmp/q/bin/apxs PREFIX=/tmp/q2
system perl: perl -V
Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
  Platform:
    osname=darwin, osvers=10.0, archname=darwin-thread-multi-2level
    uname='darwin b66.apple.com 10.0 darwin kernel version 10.0.0d8: tue may 5 19:29:59 pdt
2009; root:xnu-1437.2~2release_i386 i386 '
    config_args='-ds -e -Dprefix=/usr -Dccflags=-g  -pipe  -Dldflags= -Dman3ext=3pm -Duseithreads
-Duseshrplib -Dinc_version_list=none -Dcc=gcc-4.2'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API
  Locally applied patches:
	/Library/Perl/Updates/<version> comes before system perl directories
	installprivlib and installarchlib points to the Updates directory
  Built under darwin
  Compiled at Jul  9 2009 15:07:54
  @INC:
    /Library/Perl/Updates/5.10.0/darwin-thread-multi-2level
    /Library/Perl/Updates/5.10.0
    /System/Library/Perl/5.10.0/darwin-thread-multi-2level
    /System/Library/Perl/5.10.0
    /Library/Perl/5.10.0/darwin-thread-multi-2level
    /Library/Perl/5.10.0
    /Network/Library/Perl/5.10.0/darwin-thread-multi-2level
    /Network/Library/Perl/5.10.0
    /Network/Library/Perl
    /System/Library/Perl/Extras/5.10.0/darwin-thread-multi-2level
    /System/Library/Perl/Extras/5.10.0
    .


after make and make install I got .so file.

When I try to start apache now I get an error:
./apachectl  start
httpd: Syntax error on line 53 of /tmp/q/conf/httpd.conf: Cannot load /tmp/q/modules/mod_perl.so
into server: dlopen(/tmp/q/modules/mod_perl.so, 10): Symbol not found: _ap_add_input_filter\n
 Referenced from: /tmp/q/modules/mod_perl.so\n  Expected in: flat namespace\n in /tmp/q/modules/mod_perl.so

I decided to perform static installation but was not successful too:
I tried to build via:
perl Makefile.PL MP_USE_STATIC=1 MP_AP_PREFIX=/tmp/httpd-2.2.14 MP_AP_CONFIGURE="--with-mpm=prefork"
PREFIX=/tmp/q3

...
mod_perl.c:768: error: storage class specified for parameter 'modperl_destruct_level'
mod_perl.c:768: error: parameter 'modperl_destruct_level' is initialized
mod_perl.c:771: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
mod_perl.c:778: error: expected ';', ',' or ')' before '*' token
mod_perl.c:788: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
mod_perl.c:823: error: expected ')' before '*' token
mod_perl.c:833: error: expected ')' before '*' token
mod_perl.c:904: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'modperl_cmds'
mod_perl.c:961: error: expected declaration specifiers before ';' token
mod_perl.c:963: error: expected ')' before '*' token
mod_perl.c:986: error: expected ')' before '*' token
mod_perl.c:994: error: expected ')' before '*' token
mod_perl.c:1016: error: expected ')' before '*' token
mod_perl.c:1057: error: expected ')' before '*' token
mod_perl.c:1140: error: expected '=', ',', ';', 'asm' or '__attribute__' before '{' token
mod_perl.c:1145: error: expected declaration specifiers before 'module'
mod_perl.c:1153: error: expected declaration specifiers before ';' token
mod_perl.c:1153: error: old-style parameter declarations in prototyped function definition
/tmp/httpd-2.2.14/srclib/apr/include/apr_errno.h:52: error: parameter name omitted
mod_perl.c:1153: error: expected '{' at end of input
make[1]: *** [mod_perl.o] Error 1
make: *** [modperl_lib] Error 2


any ideas how to make step further?
--


Mime
View raw message