perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: [mp2] Apache2::Reload missing in FreeBSD ports
Date Sat, 05 Sep 2009 02:50:21 GMT
Michiel Beijen wrote:
> Foo JH wrote:
>> 2. I can't install p5-Apache-Reload over ports, as it will complain it
>> expects Apache 1.3.
> 
> This would be actually more of a FreeBSD Ports related issue.
> 
> I guess you should complain at the port maintainer for the dependencies.
> Apache-Reload is a bundle and should work with Apache2 as well as with
> Apache 1.x.
> See [http://www.freshports.org/www/p5-Apache-Reload/] for the port
> maintainer.
> 
> You could, of course, just install Apache::Reload via cpan to solve your
> issues, or tell your package manager to ignore dependencies and install
> anyway.
> 
> Regards,
> 
> Michiel


WITH_MODPERL2=yes is std option used by many ports.

Also, you didn't read the output from www/mod_perl2 that tells you to
install it (www/p5-Apache-Relaod); though it doesn't mention the above var.

WITH_MODPERL2=yes will actually be dying sometime in 2010 and everything
will be derived from the APACHE_PORT /etc/make.conf var which will soon
default to www/apache22 instead of www/apache13.



-- 
------------------------------------------------------------------------
1024D/DB9B8C1C B90B FBC3 A3A1 C71A 8E70  3F8C 75B8 8FFB DB9B 8C1C
Philip M. Gollucci (pgollucci@p6m7g8.com) c: 703.336.9354
Consultant          - P6M7G8 Inc.                http://p6m7g8.net
Senior Sys Admin    - RideCharge, Inc.           http://ridecharge.com
ASF Member          - Apache Software Foundation http://apache.org
FreeBSD Committer   - FreeBSD Foundation         http://freebsd.org

Work like you don't need the money,
love like you'll never get hurt,
and dance like nobody's watching.

Mime
View raw message