perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Prime <adam.pr...@utoronto.ca>
Subject Re: Apache::Bootstrap 0.07-rc1 available for testing
Date Fri, 10 Jul 2009 14:07:10 GMT
Fred Moyer wrote:
> I'd love it if you could take this rc for a spin and report back.  
> Passing all tests on OS X 10.5, 5.8.8, 2.2.6
> and Centos 5.2, 5.8.9, 2.2.8.
> 
> I resolved some issues while implementing this version for Apache::Dispatch.
> 
> Changes since 0.06
> 
>     - fix syntax error in params validation in new (mp2 param unchecked)
>     - warn instead of dying in new if a module is not present, and then
>       decide if any modules are present to create a new bootstrap object
> 
> 
> http://people.apache.org/~phred/Apache-Bootstrap-0.07-rc1.tar.gz

make and make test ok on...



Summary of my perl5 (revision 5 version 8 subversion 6) configuration:
   Platform:
     osname=linux, osvers=2.4.26-gentoo-r9, archname=i686-linux

PERL_DL_NONLAZY=1 /usr/bin/perl5.8.6 "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load.........# bootstrapping mp1 only
mod_perl not present, cannot bootstrap mp1 at 
/home/adam/Apache-Bootstrap-0.07-rc1/blib/lib/Apache/Bootstrap.pm line 96.
# bootstrapping mp2 only
t/00-load.........ok 3/11# Testing Apache::Bootstrap 0.07-rc1, Perl 
5.008006, /usr/bin/perl5.8.6
t/00-load.........ok 6/11Apache::Test version is 1.27, minimum version 
required is 1.28, tests will be skipped
t/00-load.........ok
         6/11 skipped: various reasons
t/pod-coverage....skipped
         all skipped: Test::Pod::Coverage 1.08 required for testing POD 
coverage
t/pod.............skipped
         all skipped: Test::Pod 1.22 required for testing POD
All tests successful, 2 tests and 6 subtests skipped.
Files=3, Tests=11,  2 wallclock secs ( 1.38 cusr +  0.07 csys =  1.45 CPU)


Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
   Platform:
     osname=linux, osvers=2.6.24-gentoo-r8, archname=i686-linux

PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load...........1/11 # bootstrapping mp1 only
mod_perl not present, cannot bootstrap mp1 at 
/home/adam/Apache-Bootstrap-0.07-rc1/blib/lib/Apache/Bootstrap.pm line 96.
# bootstrapping mp2 only
# Testing Apache::Bootstrap 0.07-rc1, Perl 5.008008, /usr/bin/perl5.8.8
Apache::Test version is 1.31, minimum version required is 1.32, tests 
will be skipped
t/00-load...........ok
t/pod-coverage......skipped: Test::Pod::Coverage 1.08 required for 
testing POD coverage
t/pod...............ok
All tests successful.
Files=3, Tests=12,  1 wallclock secs ( 0.02 usr  0.00 sys +  0.67 cusr 
0.10 csys =  0.79 CPU)
Result: PASS




Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
   Platform:
     osname=solaris, osvers=2.10, archname=i86pc-solaris

PERL_DL_NONLAZY=1 /oanda/system/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load.t ....... 1/11 # bootstrapping mp1 only
mod_perl not present, cannot bootstrap mp1 at 
/home/aprime/Apache-Bootstrap-0.07-rc1/blib/lib/Apache/Bootstrap.pm line 96.
# bootstrapping mp2 only
# Testing Apache::Bootstrap 0.07-rc1, Perl 5.008008, /oanda/system/bin/perl
Apache::Test version is 1.31, minimum version required is 1.32, tests 
will be skipped
t/00-load.t ....... ok
t/pod-coverage.t .. skipped: Test::Pod::Coverage 1.08 required for 
testing POD coverage
t/pod.t ........... ok
All tests successful.
Files=3, Tests=12,  2 wallclock secs ( 0.04 usr  0.02 sys +  0.50 cusr 
0.12 csys =  0.68 CPU)
Result: PASS



Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
   Platform:
     osname=solaris, osvers=2.10, archname=i86pc-solaris

PERL_DL_NONLAZY=1 /oanda/system/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load.t ....... 1/11 # bootstrapping mp1 only
# bootstrapping mp2 only
mod_perl2 not present, cannot bootstrap mp2 at 
/home/aprime/Apache-Bootstrap-0.07-rc1/blib/lib/Apache/Bootstrap.pm line 
121.
# Testing Apache::Bootstrap 0.07-rc1, Perl 5.008008, /oanda/system/bin/perl
Subroutine boot redefined at 
/oanda/system/lib/site_perl/i86pc-solaris/mod_perl.pm line 10.
Subroutine hook redefined at 
/oanda/system/lib/site_perl/i86pc-solaris/mod_perl.pm line 22.
Subroutine import redefined at 
/oanda/system/lib/site_perl/i86pc-solaris/mod_perl.pm line 31.
t/00-load.t ....... ok
t/pod-coverage.t .. skipped: Test::Pod::Coverage 1.08 required for 
testing POD coverage
t/pod.t ........... ok
All tests successful.
Files=3, Tests=12,  0 wallclock secs ( 0.04 usr  0.02 sys +  0.24 cusr 
0.05 csys =  0.35 CPU)
Result: PASS



Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
   Platform:
     osname=linux, osvers=2.6.24-19-server, 
archname=i486-linux-gnu-thread-multi

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-load.........1/11 # bootstrapping mp1 only
mod_perl not present, cannot bootstrap mp1 at 
/local/aprime/Apache-Bootstrap-0.07-rc1/blib/lib/Apache/Bootstrap.pm 
line 96.
# bootstrapping mp2 only
# Testing Apache::Bootstrap 0.07-rc1, Perl 5.008008, /usr/bin/perl
Apache::Test version is 1.31, minimum version required is 1.32, tests 
will be skipped
t/00-load.........ok
t/pod-coverage....ok
t/pod.............ok
All tests successful.


Adam

Mime
View raw message