perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <randy.ko...@gmail.com>
Subject Re: Using mod_perl on Vista - get Error - Can't load Perl module ModPerl::Registry
Date Mon, 01 Jun 2009 03:38:18 GMT
On Sat, May 30, 2009 at 10:49 AM, Mahesh Khambadkone
<mahesh@games2win.com> wrote:
> Hi,
>
> I followed instructions at
> http://perl.apache.org/docs/2.0/os/win32/install.html and
> http://perl.apache.org/docs/2.0/rename.html to install mod_perl on my
> configuration : Windows Vista, perl v5.10.0, ActivePerl 5.10.0 and Apache
> 2.3.
>
> I can run sample a sample Hello.pm using the following in my httpd.conf :
>
> PerlModule Apache2::Hello
> <Location /hello>
>             SetHandler modperl
>             PerlResponseHandler Apache2::Hello
> </Location>
>
> But, if I want to run old Perl CGI scripts by adding a block like the
> following, Apache throws an error “Can't load Perl module ModPerl::Registry
> for server XXX, so exiting ”.
>
> PerlModule ModPerl::Registry
> PerlSendHeader On
> <Directory /var/www/mkperl>
>      SetHandler perl-script
>     PerlHandler ModPerl::Registry
>     Options +ExecCGI
>     Order allow,deny
>     Allow from all
> </Directory>
>
> What could be wrong?

That's strange that the Apache2::Hello handler worked, but not the
registry script. Does the example at
     http://perl.apache.org/docs/2.0/os/win32/config.html#Registry_scripts
lead to the same error?

-- 
best regards,
Randy

Mime
View raw message