perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike OK" <m...@acorg.com>
Subject Re: Problem installing mod_perl2 on Clarkconnect [solved]
Date Mon, 15 Jun 2009 23:33:18 GMT
Hi Fred

    Thanks for your help.  I removed all of apache 2.0 and upgraded to 2.2 
I also removed all previous files that were installed while building 
mod_perl.  I then rebuilt mod_perl from the command line with 2.0.4.  Those 
two tests still failed while running make test.  Since it was a system wide 
config, I then su'd to root and forced the install.  After adding the 
LoadModule line and ensuring it was in the correct directory, I got the 
mod_perl message in error_log.  I am hoping that's all I need.  Mike


----- Original Message ----- 
From: "Fred Moyer" <fred@redhotpenguin.com>
To: "Mike OK" <mike@acorg.com>
Cc: <modperl@perl.apache.org>
Sent: Monday, June 15, 2009 7:15 PM
Subject: Re: Problem installing mod_perl2 on Clarkconnect


On Mon, Jun 15, 2009 at 4:04 PM, Mike OK<mike@acorg.com> wrote:
> Thanks for the reply Fred. Today I upgraded from apache 2.0 to 2.2 and
> still are having the test errors. I will continue through and install
> without test to see what happens.

You are probably fine unless you have some complex authentication code
that isn't working ok.  My app uses some auth handlers and didn't have
any issues with those failures under 2.0.4.

> Any idea where I can find 2.0.5-dev?? Mike

You can pull it from subversion here:

http://perl.apache.org/download/source.html#Development_mod_perl_2_0_Source_Distribution

>
>
> ----- Original Message ----- From: "Fred Moyer" <fred@redhotpenguin.com>
> To: "Mike OK" <mike@acorg.com>
> Cc: <modperl@perl.apache.org>
> Sent: Monday, June 15, 2009 6:52 PM
> Subject: Re: Problem installing mod_perl2 on Clarkconnect
>
>
>> On Mon, Jun 15, 2009 at 8:19 AM, Mike OK<mike@acorg.com> wrote:
>>>
>>> t/hooks/authen_basic.t (Wstat: 0 Tests: 4 Failed: 1)
>>> Failed test: 4
>>> t/hooks/authz.t (Wstat: 0 Tests: 4 Failed: 1)
>>> Failed test: 4
>>> Files=238, Tests=2557, 193 wallclock secs ( 3.25 usr 0.91 sys + 151.19
>>> cusr
>>> 26.60 csys = 181.95 CPU)
>>> Result: FAIL
>>> Failed 2/238 test programs. 2/2557 subtests failed.
>>
>> Pretty sure those are fixed in 2.0.5-dev
>>
>>> I ignored the error and forced an install as root anyway and my machine
>>> says
>>> mod_perl2 is up to date. When I restart apache, I get no mod_perl 
>>> enabled
>>> message in error_log.
>>
>> You could try adding this after the LoadModule directive:
>>
>> PerlModule Apache2::Const;
>> PerlChildInitHandler sub { say("process $$ is born to serve"); return
>> Apache2::Const::OK }
>>
>> or some variation on that, and you'll see a message in the log for
>> each mod_perl enabled child process that starts up
>>
>>
>>
>>>
>>> I have include the loadmodule line inside of httpd.conf.
>>> LoadModule perl_module modules/mod_perl.so
>>>
>>> /httpd/logs/error_log
>>> [Sun Jun 14 22:43:41 2009] [notice] Apache configured -- resuming normal
>>> operations
>>> [Mon Jun 15 00:12:24 2009] [notice] caught SIGTERM, shutting down
>>> [Mon Jun 15 00:12:24 2009] [notice] suEXEC mechanism enabled (wrapper:
>>> /usr/sbin/suexec)
>>> [Mon Jun 15 00:12:24 2009] [notice] Digest: generating secret for digest
>>> authentication ...
>>> [Mon Jun 15 00:12:24 2009] [notice] Digest: done
>>> [Mon Jun 15 00:12:24 2009] [notice] LDAP: Built with OpenLDAP LDAP SDK
>>> [Mon Jun 15 00:12:24 2009] [notice] LDAP: SSL support unavailable
>>> [Mon Jun 15 00:12:24 2009] [notice] Apache configured -- resuming normal
>>> operations
>>>
>>> Any help would be greatly appreciated
>>> Thanks Mike
>>>
>>>
>>
>
>
>



Mime
View raw message