perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <randy.ko...@gmail.com>
Subject Re: Load Failure on RequestUtill.dll
Date Fri, 17 Apr 2009 17:54:10 GMT
On Fri, Apr 17, 2009 at 11:18 AM, Dan Evans <devans@invores.com> wrote:
> I tried installing mod_perl (2.03) on my Win XP Pro (SP3) system (using ppm
> and the theoryx5.uwinnipeg.ca repository).  With perl58.dll and mod_perl.so
> added to http.conf, httpd (Apache 2.052) restarted correctly.  But, if
> either PerlModule ModPerl::PerlRun or PerlModule ModPerl::Registry was added
> to httpd.conf, httpd start would fail.
>
> After much trial and error, it appeared that Apache2::RequestUtil would not
> load because the corresponding RequestUtil.dll load failed.  After looking
> at the imports in auto/Apache2/RequestUtil/RequestUtil.dll, it seemed that
> it tried to import the symbol modperl_pnotes which was not exported from the
> mod_perl.so downloaded by ppm.
>
> The MD5 hash for the downloaded mod_perl.so is
> 6ac2e66ed1271dd89d484ea3b0b3b62f.
>
> Was RequestUtil.dll built with a later version of mod_perl.so than is in the
> repository?  Has anyone else seen this problem?

That MD5 has doesn't seem to match the corresponding one in our
repository. Could you try uninstalling mod_perl through the ppm
utility (as well as manually removing mod_perl.so), and then
reinstalling it? For Apache/2.0, the ppm package in our repository is
named mod_perl-2.0, so it should be installable via
  C:\> ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl-2.0.ppd
Does that help with this problem?

-- 
best regards,
Randy

Mime
View raw message