perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Evans <dev...@invores.com>
Subject Load Failure on RequestUtill.dll
Date Fri, 17 Apr 2009 16:18:02 GMT
I tried installing mod_perl (2.03) on my Win XP Pro (SP3) system (using ppm and the theoryx5.uwinnipeg.ca
repository).  With perl58.dll and mod_perl.so added to http.conf, httpd (Apache 2.052) restarted
correctly.  But, if either PerlModule ModPerl::PerlRun or PerlModule ModPerl::Registry was
added to httpd.conf, httpd start would fail.

After much trial and error, it appeared that Apache2::RequestUtil would not load because the
corresponding RequestUtil.dll load failed.  After looking at the imports in auto/Apache2/RequestUtil/RequestUtil.dll,
it seemed that it tried to import the symbol modperl_pnotes which was not exported from the
mod_perl.so downloaded by ppm.

The MD5 hash for the downloaded mod_perl.so is 6ac2e66ed1271dd89d484ea3b0b3b62f.

Was RequestUtil.dll built with a later version of mod_perl.so than is in the repository? 
Has anyone else seen this problem?

Dan

Mime
View raw message