perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Prime <adam.pr...@utoronto.ca>
Subject Re: generated report (was Re: mp2 hangs when running make test)
Date Sat, 21 Mar 2009 15:33:35 GMT
Oliver Block wrote:
> 
> As system user without root priviliges:
> 
> 1. Problem Description:
> 
> Two problems: 
> 
> The test tends to hang after logging that 28 vhosts are ready to test. 
> 
> If not the test does not hang, then the following summary is given:
> 
> Failed Test     Stat Wstat Total Fail  List of Failed
> -------------------------------------------------------------------------------
> t/apache/util.t                8    4  1-4
> 7 tests and 1 subtest skipped.
> Failed 1/238 test scripts. 4/2457 subtests failed.
> Files=238, Tests=2457, 133 wallclock secs (89.24 cusr + 16.95 csys = 106.19 
> CPU)
> Failed 1/238 test programs. 4/2457 subtests failed.
> [warning] server localhost:8529 shutdown
> [  error] error running tests (please examine t/logs/error_log)
> +--------------------------------------------------------+
> | Please file a bug report: http://perl.apache.org/bugs/ |
> +--------------------------------------------------------+
> make: *** [run_tests] Fehler 1

I've had the tests occasionally hang on me for no apparent reason, or 
because of a firewall on the local machine interfering with access to 
localhost.

I built mp2 2.0.4 with apache 2.2.11 yesterday (on gentoo) and didn't 
see any failed tests.  that was on a self built apache though, it looks 
like you might be building against a suse shipped on?

Adam

Mime
View raw message