perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Prime <adam.pr...@utoronto.ca>
Subject Re: Apache::compat, perldoc modules?
Date Wed, 28 Jan 2009 04:37:16 GMT
Mark Hedges wrote:
> Trying to get perldoc running in some fashion under Apache2
> with libapreq2.
> 
> I thought I'd use Apache2::Pod::HTML but no luck:
> 
> [Tue Jan 27 14:55:04 2009] [error] [client 70.143.68.29]
> Can't locate object method "send_http_header" via package
> "Apache2::RequestRec" at
> /usr/lib/perl5/site_perl/5.8.8/Apache2/Pod/HTML.pm line
> 173.\n

send_http_header does not exist in the mod_perl2 api.  Really, that's a 
bug in Apache2::Pod::HTML

> Apache::Perldoc has the same problem:
> 
> [Tue Jan 27 15:00:49 2009] [error] [client 70.143.68.29]
> Can't locate object method "send_http_header" via package
> "Apache2::RequestRec" at
> /usr/lib/perl5/site_perl/5.8.8/Apache/Perldoc.pm line 8.\n
> 
> So I thought I'd use Apache::compat even though this may
> bork some of my other code, but no luck.  This may be a
> documentation error at
> http://perl.apache.org/docs/2.0/api/Apache/compat.html,
> which says:

This file is, i think, outdated, and you should instead look at this:

http://perl.apache.org/docs/2.0/api/Apache2/compat.html

>   # either add at the very beginning of startup.pl
>   use Apache2
>   use Apache::compat;
>   # or httpd.conf
>   PerlModule Apache2
>   PerlModule Apache::compat
> 
> <snip>

This stuff looks like documentation from before the API change that was 
updated with sed, but not really read.  It should likely be removed.

Adam


Mime
View raw message