perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: Apache::Reload - ModPerl::Util::unload_package under perl 5.10 use base directive malfunction
Date Sun, 28 Dec 2008 07:45:32 GMT
David Ihnen wrote:
> 1. Problem Description:
> 
> While developing with CGI::Application and utilizing Apache::Reload, we 
> encountered an issue where our modules were not being succesfully 
> reinitialized on reload.  It was traced down to @ISA not containing the 
> proper values after a 'use base' directive, but only on automatic 
> reload, and freshly on perl 5.10, not our previous version of perl 5.8.8!
Are you able to try 5.8.9, its at least a smaller change set to look at if 
5.8.9 breaks too.




-- 
------------------------------------------------------------------------
1024D/DB9B8C1C B90B FBC3 A3A1 C71A 8E70  3F8C 75B8 8FFB DB9B 8C1C
Philip M. Gollucci (pgollucci@p6m7g8.com) c: 703.336.9354
Consultant          - P6M7G8 Inc.                http://p6m7g8.net
Director IT         - RideCharge, Inc.           http://ridecharge.com
Contractor          - PositiveEnergyUSA          http://positiveenergyusa.com
ASF Member          - Apache Software Foundation http://apache.org
FreeBSD Committer   - FreeBSD Foundation         http://freebsd.org

Work like you don't need the money,
love like you'll never get hurt,
and dance like nobody's watching.

Mime
View raw message