perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Peters <mpet...@plusthree.com>
Subject Re: Apache 1.3 -> 2.x portability
Date Fri, 14 Nov 2008 13:47:21 GMT
Phil Carmody wrote:
> I'm currently running only Apache 1.3 (mod_perl 1.22) and am wondering what kinds of
issues there might be if I were to want to migrate my server to Apache 2.x and mod_perl 2.

> 
> Are there any things that I can do (or avoid) to make such a migration as close to trivial
as possible.

http://perl.apache.org/docs/2.0/user/porting/compat.html

The biggest problem that I've seen is that not all of the Apache:: modules on CPAN have been
ported 
to Apache2 or been setup to work for both. Most of the big ones have so it depends on what
you're 
using. And it's not that hard to port one of them if you need to.

-- 
Michael Peters
Plus Three, LP


Mime
View raw message