perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Tomilson" <scott.tomil...@gmail.com>
Subject Re: "Free to wrong pool" error in Apache logs under high load
Date Fri, 10 Oct 2008 00:02:40 GMT
Thanks Perrin.

I am running a build of mod_perl I got via perl.apache.org, yes (or I think
probably linked to uwinnipeg?).  No other modules than the standard ones,
plus the standard ActivePerl download from ActiveState.  We actually tried
the same solution on Solaris and it worked fine.  It does seem specific to
Windows itself - or more likely ActivePerl on Windows...

Cheers,
Scott

On Fri, Oct 10, 2008 at 12:03 AM, Perrin Harkins <perrin@elem.com> wrote:

> On Thu, Oct 9, 2008 at 3:07 AM, Scott Tomilson <scott.tomilson@gmail.com>
> wrote:
> > Free to wrong pool da2750 not 184a6a8.
> >
> > Which leads me to believe there is something funny going on with multiple
> > threads, etc.
>
> In the past these have typically been threading problems.  I don't run
> Windows or threads, so I'm probably not going to be much help to you
> on this, but if you're not using a build you got from perl.apache.org
> I would consider trying that first.  Are you loading any other
> modules, or just running this one simple test?
>
> - Perrin
>

Mime
View raw message