perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Perrin Harkins" <per...@elem.com>
Subject Re: a require problem
Date Fri, 29 Aug 2008 17:21:18 GMT
On Fri, Aug 29, 2008 at 11:19 AM, Clinton Gormley <clint@traveljury.com> wrote:
> Is this not a current-working-directory issue?
>
> This isn't terribly well documented on the mod_perl site, but from
> http://perl.apache.org/docs/2.0/api/ModPerl/Registry.html

Better documented here:
http://perl.apache.org/docs/2.0/user/porting/compat.html#C_Apache__Registry___C_Apache__PerlRun__and_Friends

> Try using absolute paths for 'use lib', instead of : use lib './lib'

Or use ModPerl::RegistryPrefork.

- Perrin

Mime
View raw message