perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Axtell <daniel.axt...@snet.net>
Subject Re: Compiling Perl + mod_perl on 64-bit linux
Date Tue, 26 Aug 2008 19:01:59 GMT
On Tuesday 26 August 2008 2:28:46 pm Niels Larsen wrote:
> I dont have a good answer. But editing the Makefile may hide the real
> error .. which error appears when not editing the Makefile, and Google
> with that error, no hints? what happens if -Dloclibpth="/usr/lib64"
> is omitted? and of curiosity, what was the reason for going back to
> perl 5.8 from 5.10? (i feel 5.10 is less stable than 5.8, but doesnt
> get in my way).
>

I think if I leave out /usr/lib64, perl won't compile.   I've tried so many 
variations they kind of blend together

The make command gives this error:
make: *** No rule to make target `<command-line>', needed by `miniperlmain.o'.  
Stop

doing make -f Makefile let's perl compile, except for x2p, which gives a 
similar error.  I've worked around this by taking out lines from the makefile 
like:
av$(OBJ_EXT): <command-line>

The main reason for wanting 5.8.x is I have some legacy apps that use 
CGI::Builder, which won't compile under 5.10.  At this point I'm going to 
focus on getting it to build on 5.10, since that actually has  a working 
mod_perl binary for my AMD64  box.

Thanks for the help so far.

Mime
View raw message