perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Axtell <daniel.axt...@snet.net>
Subject Re: Compiling Perl + mod_perl on 64-bit linux
Date Tue, 26 Aug 2008 04:13:37 GMT
>
> You will need to compile perl with -fPIC on x86_64, I think I did it with:
>
> ccflags='-fPIC' sh Configure -Dprefix /path to perl
>
> I can't remember _exactly_ if that was it though.  The other options
> would be to manually the edit the Makefiles but I don't remember having
> to do that.
>

OK, I've gone through the Configure process several times.  With the latest, 
I'm able to make, test and install Perl but it won't run anything, much less 
build mod_perl, as it gives this error:

Attempt to free unreferenced scalar: SV 0xb4e570 at Makefile.PL line 34.
BEGIN failed--compilation aborted at Makefile.PL line 34.

I've built Perl with no threads, dynamic loading, DynaLoader is using 
dl_dlopen, -fPIC, and shared libperl.so.   I've tried building it without 
dynamic loading, but it won't build.  

I've tried building Perl with no dynamic loading, same results.

Any ideas?



Mime
View raw message