perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Burlaca <oburl...@neonet.md>
Subject Re: Which version of Apache: 2.2.x or 2.0.x ?
Date Fri, 25 Jul 2008 20:59:49 GMT
Thanks André
> If this may reassure you, I have been using quite a bit of mod_perl 2 
> in the last 2-3 years with Apache 2.0.x and lately 2.2.x, under 
> Solaris, HPUX, Linux and Windows, and have not had the kind of 
> problems you mention.  So yes, it looks like you may have some 
> mismatched stuff there.
Hmm, I've always used two apaches with mod_proxy. The main errors I got 
reported by the front-end apache were "proxy: error reading status line 
from remote server". But these errors are not consistent, I got them 
from time to time. I'm using libapreq2.08, mod_perl2.0.3 with httpd 
2.0.63. (perl5.8.3).
> As for versions, I would tend to recommend the latest version of 
> Apache 2.2.x you can find, and then look for the latest versions of 
> perl 5.8.x and mod_perl 2.x that fit together.
I've just got another VPS server with perl5.8.8 on it. I'll install 
httpd  2.2.9 and mod_perl 2.0.4 and test a little.
Should I get libapreq from svn or the latest stable version 2.08 is ok?

and one more question: I have read that on linux platforms it's better 
to use prefork instead of mpm-worker, I remember that we did some 
performance test ourselves and it sounds to be true.

Regards.

Mime
View raw message