perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Kremer <l...@funkreich.de>
Subject Re: Segfault when connecting during Apache startup with Apache::DBI
Date Wed, 25 Jun 2008 09:49:16 GMT
Quoting Tobias Kremer <list@funkreich.de>:

> > - Ubuntu Feisty with apache-perl.
> > - stock Ubuntu Perl 5.8.8 (which unfortunately comes with threads)
> > - self-rolled DBD::mysql (against libmysqlclient15-dev), DBI and
> Apache::DBI
>
> I should have mentioned that we're using DBI 1.605, Apache::DBI 1.07 and
> DBD::mysql 4.007. The Ubuntu apache-perl package consists of Apache 1.3.34
> and
> mod_perl/1.29.

After de-installing the latest (self-rolled) DBI and DBD::mysql modules and
installing the corresponding packages provided by Ubuntu (libdbd-mysql-perl and
libdbi-perl) the segfaults are gone. Anyone know what could have gone wrong
during make'ing my own DBI/DBD::mysql? I'd really like to use the most current
versions of those two modules instead of the outdated Ubuntu ones (DBI 1.53,
DBD::mysql 3.0008).

--Tobias

Mime
View raw message