perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valerio <valerio.bonte...@gmail.com>
Subject Re: HTTP request using mod_perl - permission denied on localhost
Date Thu, 17 Apr 2008 15:09:49 GMT
Hi all,

I solved the problem:
it is not a problem of mod_perl, or perl, or linux... it is a problem
of Fedora and SELinux, which prevents a cgi to open a socket on the
same system...


Valerio

2008/4/17, Valerio <valerio.bontempi@gmail.com>:
> Hi all,
>
>  I have a mod_perl script which works at PerlTransHandler level, and
>  translates the virtual host requested to the real system path where
>  site's pages are stored.
>  To do this translation, I tried two solutions:
>  - ask to a db
>  - ask to a php script on another apache which makes the traslation.
>
>  But the second solution doesn't work in every situation:
>  if the second apache is on the same system but different port, it
>  doesn't work and I find on the error_log
>
>  500 Can't connect to 192.168.2.110:8080 (connect: Permission denied)
>
>  (also if I use a different Ip, using an alias for the network interface)
>
>  Otherwise, if it is on another system, it works.
>
>  Does anyone know why it happens?
>  Is it a limitation of apache/mod_perl?
>
>  Thanks and regards
>
>
>  Valerio
>

Mime
View raw message