perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Beginner" <der...@sciencephoto.com>
Subject Re: troubleshooting
Date Mon, 17 Mar 2008 14:11:38 GMT
On 17 Mar 2008 at 12:56, Jeff Armstrong wrote:

> Dp,
> 
> Make sure you are using etch or later:
>   dpkg -l libapache2-mod-perl2
> 
> should list the installed version as 2.0.2-2.4 
> 
> 
> The sarge libapache2-mod-perl2 versions (1.99.xxx) were not sane.


Apache/2.2.3 (Debian) mod_perl/2.0.2 Perl/v5.8.8

dpkg -l libapache2-mod-perl2 shows:

ii  libapache2-mod-perl2      2.0.2-2.4

It doesn't mention etch but I think this is the correct version.

My archive for apt doesn't have the libapache2-mod-perl2.deb file any 
longer. So I downloaded the version for my hardware (Alpha) and tried 
again:

Unpacking replacement libapache2-mod-perl2 ...
Setting up libapache2-mod-perl2 (2.0.2-2.4) ...
apache2 -k start ; tail -f /var/log/apache2/error.log

Subroutine load redefined at /usr/lib/perl5/Apache2/XSLoader.pm line 
28.\nCompilation failed in require at 
/usr/lib/perl5/Apache2/RequestRec.pm 

I am lost at this point. I think my install is correct in terms of 
version numbers. 

RequestRec reads:
 
use Apache2::XSLoader ();
our $VERSION = '2.000002';
Apache2::XSLoader::load __PACKAGE__;

XSLoader doesn't offer a version number.

I'd appreciate any ideas at this point. Thanx.
Dp.



Mime
View raw message