perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Issac Goldstand <mar...@beamartyr.net>
Subject Re: [RELEASE CANDIDATE] mod_perl-1.31 RC3
Date Sat, 01 Mar 2008 17:01:33 GMT

Built APSource-1002 using default settings and had the same segfault.

Randy Kobes wrote:
> On Thu, 28 Feb 2008, Issac Goldstand wrote:
> 
>> Steve Hay wrote:
>>> Issac Goldstand wrote:
>>>
>>>> win32  (xp sp2, vc6 - no SDK upgrade) - Apache 1.41 binary -
>>>> ActivePerl 5.10 (build 1002)
>>>> FAIL
>>>>
>>>> (sorry, folks)
>>>>
>>>> Segfault at startup.
>>>
>>> I wonder if this is caused by mis-matched CRTs? ActivePerl is built
>>> using VC6 (and therefore uses MSVCRT.dll). You're also using VC6 for
>>> mod_perl, but where did that Apache binary come from? What compiler was
>>> it built with?
>>>
>>> Does it work if you build everything yourself from source with the same
>>> compiler?
>>>
>> I'm reasonably sure that Apache's binaries are still being built with 
>> vc6, which is what prompted me to test this particular set of 
>> prerequisites (since binary Apache + binary ActivePerl will be the 
>> assumed building blocks for a binary PPM package to be installed 
>> upon).   Bill, am I wrong about the compiler used for the ASF binary 
>> release of apache-1.3 win32?
> 
> I also got a segfault at startup with ActivePerl 1002
> (perl-5.10), using an ASF apache binary and VC++ 6.
> All tests passed with the latest ActivePerl 8xx, based on
> perl-5.8, using the same Apache binary and compiler.
> Steve, is your Perl built using the ActivePerl sources,
> with the same compile-time flags as ActivePerl?
> 

Mime
View raw message